Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000096 [libFirm] analyses minor always 2012-09-28 08:47 2016-01-03 03:28
Reporter zwinkau View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000096: Assertion `spillinfo->spill_costs >= 0' failed
Description $ cparser -version
cparser (332b74940b94b8f2bfbd6dc12f97558d307d1abd-dirty) using libFirm (1.20-2b76ea5c55c405a6aefc64ffa07b8c810a7fd7f1)
$ cparser -O3 -fno-thread-jumps spillcrash.c
...
cparser: ir/be/bespillutil.c:407: spill_irn: Assertion `spillinfo->spill_costs >= 0' failed.
Additional Information
Tags No tags attached.
Attached Files c file icon spillcrash.c [^] (118,901 bytes) 2012-09-28 08:47

- Relationships

-  Notes
(0000143)
Matze (administrator)
2012-09-28 12:47

execution frequency information for func_7 is messed up, it's inf or nan for every block. I did not check yet why this happens.
(0000223)
Matze (administrator)
2014-09-29 10:25

seems to be fixed in latest revision. Probably due to execfreq solver improvements.

- Issue History
Date Modified Username Field Change
2012-09-28 08:47 zwinkau New Issue
2012-09-28 08:47 zwinkau File Added: spillcrash.c
2012-09-28 12:47 Matze Note Added: 0000143
2012-09-28 12:47 Matze Status new => confirmed
2012-09-28 12:48 Matze Project cparser => libFirm
2012-09-28 12:48 Matze Category other => analyses
2014-09-29 10:25 Matze Note Added: 0000223
2014-09-29 10:25 Matze Status confirmed => resolved
2014-09-29 10:25 Matze Resolution open => fixed
2016-01-03 03:28 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker