Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000068 [libFirm] other crash always 2011-06-22 13:48 2011-12-24 03:47
Reporter piper View Status public  
Assigned To Matze
Priority normal Resolution fixed  
Status closed   Product Version development
Summary 0000068: assert failed related to X_except
Description After a fairly recent change (possibly 6b45fde8), my cparser build aborts on source files containing calls:

$ cat t.c
void foo(void);
void bar(void) { foo(); }
$ cparser -S -o - t.c
cparser: ../../ir/ir/irverify.c:743: verify_node_Proj_fragile: Assertion `((!is_x_except_Proj(node) || throws_exception) && (!is_x_regular_Proj(node) || throws_exception)) && "X_except und X_regular Proj only allowed when throws_exception is set"' failed.

Here are a few details from a gdb session:

(gdb) p is_x_except_Proj(node)
$4 = 1
(gdb) p throws_exception
$5 = 0
(gdb) p is_x_regular_Proj(node)
$6 = 1
(gdb) p dump_irnode_to_file(stderr, node)
Proj 63
  index: 14
  addr: 0x4cc290
  mode: M
  visited: 0
  irg: bar
  arity: 1
  pred nodes:
    -1: Block 59
     0: Call 62
  Private Attributes:
  proj nr: 0

(gdb) p get_Proj_pred(node)->op->pn_x_regular
$13 = 0
(gdb) p get_Proj_pred(node)->op->pn_x_except
$14 = 0
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000127)
Matze (administrator)
2011-10-19 22:16

oh sorry for the late answer. Anyway, this looks like a rebuild Problem because these enum values changed (we had some dependency problems in the Jamfiles with the automatically generated files). A jam clean/make clean should get you going again.

- Issue History
Date Modified Username Field Change
2011-06-22 13:48 piper New Issue
2011-10-19 22:16 Matze Note Added: 0000127
2011-10-19 22:16 Matze Assigned To => Matze
2011-10-19 22:16 Matze Status new => resolved
2011-10-19 22:16 Matze Resolution open => fixed
2011-12-24 03:47 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker