Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000061 [cparser] lexer minor always 2010-10-19 14:19 2016-01-03 03:28
Reporter Matze View Status public  
Assigned To Matze
Priority low Resolution fixed  
Status closed   Product Version
Summary 0000061: reported line for 'invalid byte sequence' is invalid
Description lines reported in the 'invalid byte sequence' error message are way of!
Additional Information The UTF-8 decoding routines use parse_error() calls to report errors. The problem here is that while we decode a bigger block of characters we do not count newlines yet so the reported lines for the invalid byte sequences are at the beginning of the decoded block and not where the error really is.

A simple solution would be to just not display line number information there. The advanced solution would count the number of newlines in the block and add them to the reported line number.
Tags No tags attached.
Attached Files c file icon cl_keys.c [^] (281,088 bytes) 2010-10-19 15:04

- Relationships

-  Notes
(0000092)
zwinkau (manager)
2010-10-19 15:05

Added a file where the encoding is broken to test this bug. The c code is preprocessed so it should just compile.
(0000168)
Matze (administrator)
2013-08-10 03:51

this should be fixed since cparser rev 6c2acf3808994a6b6f868c2f3c9020b2e1e0e8d3

- Issue History
Date Modified Username Field Change
2010-10-19 14:19 Matze New Issue
2010-10-19 15:04 zwinkau File Added: cl_keys.c
2010-10-19 15:05 zwinkau Note Added: 0000092
2011-06-07 12:55 Matze Severity major => minor
2012-09-28 12:56 Matze Status new => confirmed
2013-08-10 03:51 Matze Note Added: 0000168
2013-08-10 03:51 Matze Assigned To => Matze
2013-08-10 03:51 Matze Status confirmed => resolved
2013-08-10 03:51 Matze Resolution open => fixed
2016-01-03 03:28 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker