Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000021 [cparser] firm graph generation major always 2008-12-13 13:10 2009-01-28 21:55
Reporter Matze View Status public  
Assigned To Matze
Priority normal Resolution fixed  
Status closed   Product Version 0.9.7
Summary 0000021: floating point constant folding does not work
Description cparser does not fold floating point constants, because we haven't found a way to model the x86 specifics correctly yet (ie. 80bit inside of expressions, 64bit in assignments).
It's also unclear wether libfirms tarval calculates with the exact number of bits specified in the mode.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000033)
Matze (administrator)
2008-12-13 20:58

fixed by several commits up to r24621

- Issue History
Date Modified Username Field Change
2008-12-13 13:10 Matze New Issue
2008-12-13 20:58 Matze Note Added: 0000033
2008-12-13 20:58 Matze Status new => resolved
2008-12-13 20:58 Matze Resolution open => fixed
2008-12-13 20:58 Matze Assigned To => Matze
2009-01-28 21:55 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker