Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000144 [cparser] compiler driver minor always 2014-07-21 16:50 2016-01-03 03:28
Reporter haass View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 0.9.14
Summary 0000144: segfault after inlining
Description compiler crashes on the attached short_term.c (part of mibench / preprocessed to get rid of the wicked macros and shortened as much as possible).

Happens with -O3 and -m32 only

Looks like get_irn_n(node, -1) is called on a BB / the start block
in lambda_partition() at combo.c:1593

No idea how to fix that properly though
Additional Information cparser -m32 -O3 short_term.i -c -o short_term.o
Tags No tags attached.
Attached Files ? file icon short_term.i [^] (4,442 bytes) 2014-07-21 16:50
c file icon combo10.c [^] (207 bytes) 2014-07-23 10:25

- Relationships

-  Notes
(0000225)
Matze (administrator)
2014-09-29 10:34

fixed in revision bc6ec4d6b02c792f897561a95d73d35ec7477f15

- Issue History
Date Modified Username Field Change
2014-07-21 16:50 haass New Issue
2014-07-21 16:50 haass File Added: short_term.i
2014-07-23 10:23 UniQ Issue Monitored: UniQ
2014-07-23 10:23 UniQ Issue End Monitor: UniQ
2014-07-23 10:25 UniQ Status new => confirmed
2014-07-23 10:25 UniQ File Added: combo10.c
2014-09-29 10:34 Matze Note Added: 0000225
2014-09-29 10:34 Matze Status confirmed => resolved
2014-09-29 10:34 Matze Resolution open => fixed
2016-01-03 03:28 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker