Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000131 [cparser] firm graph generation major always 2013-12-19 20:28 2016-01-03 03:28
Reporter luzero View Status public  
Assigned To Matze
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0000131: const function with multiple compound type parameters fails
Description The testcase is a _bit_ convoluted

It requires to build first m.o and then link together t.c and m.o.

Files attached below.
Additional Information
Tags No tags attached.
Attached Files c file icon t.c [^] (492 bytes) 2013-12-19 20:28
c file icon min.c [^] (936 bytes) 2013-12-19 20:28

- Relationships

-  Notes
(0000194)
luzero (reporter)
2013-12-19 20:29

/usr/src/cparser/build/debug/cparser -m32 -I. -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -g -Wdeclaration-after-statement -Wall -Wpointer-arith -Wredundant-decls -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wstrict-prototypes -Wno-parentheses -Wno-switch-enum -Wno-other -O4 -Wno-missing-variable-declarations -Wno-empty-statement -c -o m.o min.c

/usr/src/cparser/build/debug/cparser -m32 -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -std=c99 -fomit-frame-pointer -pthread -g -Wdeclaration-after-statement -Wall -Wpointer-arith -Wredundant-decls -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wstrict-prototypes -Wno-parentheses -Wno-switch-enum -Wno-other -O4 -Wno-missing-variable-declarations -Wno-empty-statement -o t t.c m.o

./t
(0000197)
Matze (administrator)
2014-01-10 14:34
edited on: 2014-01-10 14:35

There seems to be a bug related to const functions with multiple compound type paramters.

A single file testcase has been added as firm-testsuite/opt/fehler221.c

(0000198)
Matze (administrator)
2014-01-10 16:57

fixed in cparser revision 9549e6ec61a79307bf70b668c4fef227b72a0557

- Issue History
Date Modified Username Field Change
2013-12-19 20:28 luzero New Issue
2013-12-19 20:28 luzero File Added: t.c
2013-12-19 20:28 luzero File Added: min.c
2013-12-19 20:29 luzero Note Added: 0000194
2014-01-10 14:34 Matze Note Added: 0000197
2014-01-10 14:34 Matze Status new => confirmed
2014-01-10 14:34 Matze Summary cparser miscompiles __attribute((const)) => const function with multiple compound type parameters fails
2014-01-10 14:35 Matze Note Edited: 0000197
2014-01-10 16:57 Matze Note Added: 0000198
2014-01-10 16:57 Matze Assigned To => Matze
2014-01-10 16:57 Matze Status confirmed => resolved
2014-01-10 16:57 Matze Resolution open => fixed
2014-01-10 16:57 Matze Category compiler driver => firm graph generation
2016-01-03 03:28 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker