Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000122 [libFirm] API minor always 2013-09-18 10:06 2016-01-03 03:28
Reporter zwinkau View Status public  
Assigned To Matze
Priority normal Resolution won't fix  
Status closed   Product Version development
Summary 0000122: Generated API header: nodes.h
Description Generated header files are put into build/gen/.
Public API header files are put into include/libfirm/.
The nodes.h file is generated and public API and currently is put into build/gen/.

Problem: Breaks liboo and other libfirm users since rev e1c7cd54907fa704cd6bbc384edbcca953dbcdad since nodes.h is missing with a clean build.

Solution: Add "-I$(FIRM_HOME)/build/gen/include/libfirm" to your build flags, which is what cparser does.

Is this really a good solution? This complicates using libfirm as a submodule and probably means libfirms "make install" is broken.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0000180)
Matze (administrator)
2013-09-18 18:38

* Putting generated files anywhere except build is very annoying, as it complicated "make clean" and/or if you switch between revisions too much it leads to old files staying in your repositories (because the particular version of 'make clean' doesn't know about it anymore). So the best thing to do is bundle all generated files in the build directory.
* Distribution builders apparently like it when they can have read-only sourcecode and build to somewhere else.
* libfirm never had a working "make install" anyway as far as I know. If we really need one we should be able to fix this before the next release.

IMO adding another -I flag is not that much of a problem (or at least not worse than having randomly breaking builds when switching around revisions).
(0000186)
Matze (administrator)
2013-10-29 14:02

no further comments coming, closing the issue.

- Issue History
Date Modified Username Field Change
2013-09-18 10:06 zwinkau New Issue
2013-09-18 18:38 Matze Note Added: 0000180
2013-09-18 18:38 Matze Status new => feedback
2013-09-18 18:39 Matze Severity block => minor
2013-10-29 14:02 Matze Note Added: 0000186
2013-10-29 14:02 Matze Assigned To => Matze
2013-10-29 14:02 Matze Status feedback => resolved
2013-10-29 14:02 Matze Resolution open => won't fix
2016-01-03 03:28 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker