Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000119 [libFirm] other feature always 2013-09-05 17:56 2016-01-03 03:28
Reporter haass View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version development
Summary 0000119: make ir_snprintf return amoutn of characters used
Description ensures same behaviour as standard snprintf
Additional Information
Tags No tags attached.
Attached Files ? file icon patch_ir_snprintf_return_int.git [^] (1,245 bytes) 2013-09-05 17:56
? file icon 0016-make-ir_snprintf-return-the-amount-of-characters-use.patch [^] (1,446 bytes) 2013-09-05 18:08

- Relationships

-  Notes
(0000174)
Matze (administrator)
2013-09-13 08:59

the problem was fixed in a more consistent way in beb29b8109eeb9a544aa673ec0bab7217fef5ccf
unittest added in libfirm bb8b86605cd25e31fad033fc815b43351e7fb079

- Issue History
Date Modified Username Field Change
2013-09-05 17:56 haass New Issue
2013-09-05 17:56 haass File Added: patch_ir_snprintf_return_int.git
2013-09-05 18:08 haass File Added: 0016-make-ir_snprintf-return-the-amount-of-characters-use.patch
2013-09-13 08:59 Matze Note Added: 0000174
2013-09-13 08:59 Matze Status new => resolved
2013-09-13 08:59 Matze Resolution open => fixed
2016-01-03 03:28 Matze Status resolved => closed


Mantis 1.1.5[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker